Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: '82 - '83 GPz550 speedo repair

'82 - '83 GPz550 speedo repair 08 Oct 2019 14:49 #812079

  • smcmillen66
  • smcmillen66's Avatar Topic Author
  • Offline
  • Member
  • Member
  • Posts: 25
  • Thank you received: 1
My speedo and odo has stopped working after several months of whirring and whining. Speedo hub and cable are good. Odo worked even when speedo swinging wildly, but now both caput.
Anybody know if there's a person out there that can fix it? Are there even parts for it?
Thanks!

Please Log in or Create an account to join the conversation.

'82 - '83 GPz550 speedo repair 08 Oct 2019 17:10 #812085

  • DoctoRot
  • DoctoRot's Avatar
  • Offline
  • Member
  • Member
  • Oh, the usual... I bowl, I drive around...
  • Posts: 1904
  • Thank you received: 322
unfortunately your best bet it to try and find a used one in decent shape on ebay. Same thing happened to me on my kz1000. is you speedo hard mounted by chance? - did you remove the rubber mounts?
-Vic
_________________________________
'78 kz1000 LTD long term project

'80 kz750G project

Please Log in or Create an account to join the conversation.

Last edit: by DoctoRot.

'82 - '83 GPz550 speedo repair 08 Oct 2019 18:13 #812088

  • martin_csr
  • martin_csr's Avatar
  • Offline
  • Member
  • Member
  • Posts: 6524
  • Thank you received: 1091
From the diagrams at partzilla for the 550H you can open up the meter assy & take a look at the innards. then maybe figure out what's wrong.



....

Please Log in or Create an account to join the conversation.

'82 - '83 GPz550 speedo repair 08 Oct 2019 20:59 #812102

  • SWest
  • SWest's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 19008
  • Thank you received: 1805
A wild speedo could be a cable that's weak, twisting up like a spring then letting loose and twisting up again. Sounds like both are broken.
Steve
Z1b1000 1975 Z1b
Opinions expressed by me do not reflect those of the the staff or members
kzrider.com/forum/11-projects/598262-kz-...-will-it-live#672882
kzrider.com/forum/2-engine/597654-poser?start=240#704229

Please Log in or Create an account to join the conversation.

'82 - '83 GPz550 speedo repair 09 Oct 2019 05:54 #812116

  • martin_csr
  • martin_csr's Avatar
  • Offline
  • Member
  • Member
  • Posts: 6524
  • Thank you received: 1091
I would remove & inspect the speedo cable to make darn sure it isn't the cable. Also, if you've had the front wheel off recently, I suppose something could be amiss with the speedo drive.

....

Please Log in or Create an account to join the conversation.

'82 - '83 GPz550 speedo repair 11 Oct 2019 12:31 #812264

  • smcmillen66
  • smcmillen66's Avatar Topic Author
  • Offline
  • Member
  • Member
  • Posts: 25
  • Thank you received: 1
Thanks all. The cable and hub are in good order. not sure if it's hard-mounted. I'll keep looking for a good used one and, if I have the bike apart again, I'll try to get in there and see if I can fix it.
I did manage to source the little light bulbs from Partzilla, so I may be opening it up sooner than later.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum