Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

Leaking Accel Pump on 1980 KZ650 12 Sep 2020 09:45 #834851

  • vinchill@rcn.com
  • vinchill@rcn.com's Avatar Topic Author
  • Offline
  • Member
  • Member
  • Posts: 6
  • Thank you received: 0
I have a Mint Condition Kawasaki KZ 650. I replaced the Accel valve 3 years ago and it is Leaking again (I think) from the Alcohol in the Gasoline here in the USA. I either want to find a Kit that can handle the Alcohol or Bypass it. Anyone bypass theirs?

Please Log in or Create an account to join the conversation.

Leaking Accel Pump on 1980 KZ650 12 Sep 2020 11:04 #834861

  • 650ed
  • 650ed's Avatar
  • Offline
  • Member
  • Member
  • Posts: 15238
  • Thank you received: 2752
Pictures of your mint condition KZ650 would be appreciated. There are very, very few of them left in that condition. The earlier KZ650's such as my 1977 didn't have that pump so it really isn't necessary, but I don't know how to bypass it. Ed
1977 KZ650-C1 Original Owner - Stock (with additional invisible FIAMM horn)

Please Log in or Create an account to join the conversation.

Leaking Accel Pump on 1980 KZ650 12 Sep 2020 13:56 #834878

  • vinchill@rcn.com
  • vinchill@rcn.com's Avatar Topic Author
  • Offline
  • Member
  • Member
  • Posts: 6
  • Thank you received: 0

Attachment not found

Attachment not found

Attachment not found

Please Log in or Create an account to join the conversation.

Leaking Accel Pump on 1980 KZ650 12 Sep 2020 14:04 #834880

  • vinchill@rcn.com
  • vinchill@rcn.com's Avatar Topic Author
  • Offline
  • Member
  • Member
  • Posts: 6
  • Thank you received: 0
I have tried several times to post a Pic but it ends up not showing.

Attachment not found

Please Log in or Create an account to join the conversation.

Leaking Accel Pump on 1980 KZ650 12 Sep 2020 14:12 #834882

  • vinchill@rcn.com
  • vinchill@rcn.com's Avatar Topic Author
  • Offline
  • Member
  • Member
  • Posts: 6
  • Thank you received: 0
I made the Pics Smaller and will try again but also see I am not allowed access to some thing here I also have a 1977 SR650 in Mint Condition

Attachment not found

Attachment not found

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum