Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

Kz305 cam chain 09 Jun 2021 07:57 #849878

  • Jeffey555
  • Jeffey555's Avatar Topic Author
  • Offline
  • User
  • Posts: 2
  • Thank you received: 0
Hello 
I have a early 80s kz305 what I’m having trouble finding how to set the cam shaft timing  on 
I had to take the head off to the bolts removed but with the head back in my shop I can’t find any marks on the cam shaft as to where to set the timing for them 
I have the copy of the original manual and the repair manual and have spent several hours on google and even went to a local shop 
all with no progress 

Any suggestions are definitely appreciated 

thanks Jeff 

Please Log in or Create an account to join the conversation.

Kz305 cam chain 09 Jun 2021 11:17 #849895

  • Scirocco
  • Scirocco's Avatar
  • Offline
  • Premium Member
  • Never change a running system
  • Posts: 3154
  • Thank you received: 1377
The repair manual give you the answer to setup the cam timing right.

kzrider.com/modules/ServiceManuals/Kawas...0KZ250%20-%20305.pdf

 
Attachments:

Please Log in or Create an account to join the conversation.

Kz305 cam chain 09 Jun 2021 11:57 #849901

  • ghostdive
  • ghostdive's Avatar
  • Offline
  • User
  • Posts: 173
  • Thank you received: 42
Under the left side cover, look into the window and match the "T" mark (next to the F mark) with the arrow on the case. Then put the cam in with the line marks on the sprocket parallel to the head/valve cover mating surface. I like to do a couple full rotations after getting the chain on to make sure I have it right. 
1982 KZ750 Spectre - Dyna 2.2 coils + 8mm wires, WG coil relay, SH775 R/R, Mikuni BS34s - 40P/122.5M, Progressive fork springs/KZ900 rear shocks, Vance & Hines 4-1

1982 KZ305 CSR - 18" KZ400 rear wheel

Please Log in or Create an account to join the conversation.

Kz305 cam chain 10 Jun 2021 00:27 #849942

  • Jeffey555
  • Jeffey555's Avatar Topic Author
  • Offline
  • User
  • Posts: 2
  • Thank you received: 0
Excellent thank you guys for your help 
perhaps I had the wrong repair manual

 

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum