Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

Hmmm, tail light doesn't work at all. Brake light etc 14 Jan 2022 18:10 #860530

  • Bobdudeman
  • Bobdudeman's Avatar Topic Author
  • Offline
  • User
  • Posts: 7
  • Thank you received: 0
Having an issue with my 78 KZ650. The old headlight melted on me and I pulled it off and didn't mark the wires. The old headlight had built-in directionals as well.  The new headlight does not have directionals and I don't have directions on the rear brake light as well (I live in Florida).  So when I got my new headlight I, I found the wires to turn it on with the ignition and it seems to go from high beam to low beam, but now my rear brake light does not work at all.  Nothing happens when I compress the front brake whoever or the rear brake pedal. The brake light does not even come on. Could anybody help me to do some problem? Exactly what wires I should be looking for for the three wire headlight to make sure it's correct and make sure they rear tail light gets power please? There's a lot of information on here but I just can't seem to find the right stuff fix the issue. I'm ready to start writing again as I'm completing the build. Thank you all in advance
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by Street Fighter LTD.

Hmmm, tail light doesn't work at all. Brake light etc 14 Jan 2022 21:24 #860532

  • Scirocco
  • Scirocco's Avatar
  • Offline
  • Premium Member
  • Never change a running system
  • Posts: 3331
  • Thank you received: 1467
I think you have to try to switch the wires. LED lights are like diodes and need the correct voltage and polarity.

Black/Yellow = ground or negativ
Red  = 12 Volts+ ignition switch on
Blue = 12 Volts+ break light switch

 
 
Attachments:

Please Log in or Create an account to join the conversation.

Hmmm, tail light doesn't work at all. Brake light etc 15 Jan 2022 04:40 #860538

  • hardrockminer
  • hardrockminer's Avatar
  • Offline
  • Sustaining Member
  • Posts: 2151
  • Thank you received: 619
As shown in the diagram, the headlight has a small plug for the bulb and three wires.  They are Red/black, Red/yellow and Black/yellow.  They have male connectors and should connect to the same colours in the main harness.  From the harness side The black/yellow should have a double female connector.  From memory, one of the others does as well but I can't remember which one.
I have several restored bikes along with a 2006 Goldwing with a sidecar. My wife has a 2019 Suzuki DR 650 for on and off road.

Please Log in or Create an account to join the conversation.

Hmmm, tail light doesn't work at all. Brake light etc 15 Jan 2022 07:53 #860546

  • F64
  • F64's Avatar
  • Offline
  • User
  • 81-KZ440D2
  • Posts: 729
  • Thank you received: 193
Did you modify the wire harness?
In previous posts you mentioned how you wanted a minimal wiring harness for your bike.
81-KZ440-D2.
Louis Dudzik's GM HEI ignitor conversion installed 2015 s3.amazonaws.com/gpzweb/Ignition/GPZgmHEImod.html
Motogadget m-unit blue installed 2017.
LIC, NY

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum